[UVA] 297 - Quadtrees@Morris' Blog|PChome Online 個人新聞台
24h購物| | PChome| 登入
2012-04-30 07:07:34| 人氣1,917| 回應0 | 上一篇 | 下一篇

[UVA] 297 - Quadtrees

推薦 0 收藏 0 轉貼0 訂閱站台


 Quadtrees 

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

A modern computer artist works with black-and-white images of tex2html_wrap_inline34 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter 'p' indicates a parent node, the letter 'f' (full) a black quadrant and the letter 'e' (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output Specification

For each test case, print on one line the text 'There are X black pixels.', where X is the number of black pixels in the resulting image.

Example Input

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Example Output

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.



#include <stdio.h>
#include <string.h>
int idx;
char map[33][33];
char tree[3024];
void color(int x, int y, int b2) {
    char c = tree[idx];
     if(c == 'p') {
        idx++;
        color(x, y+b2/2, b2/2);
        color(x, y, b2/2);
        color(x+b2/2, y, b2/2);
        color(x+b2/2, y+b2/2, b2/2);
    } else if(c == 'f') {
        int i, j;
        for(i = x; i < x+b2; i++) {
            for(j = y; j < y+b2; j++) {
                map[i][j] = 1;
            }
        }
        idx++;
    } else
        idx++;
}
int main() {
    int t, i, j;
    scanf("%d", &t);
    getchar();
    while(t--) {
        memset(map, 0, sizeof(map));
        scanf("%s", tree);
        idx = 0;
        color(0, 0, 32);
        scanf("%s", tree);
        idx = 0;
        color(0, 0, 32);
        int ans = 0;
        for(i = 0; i < 32; i++)
            for(j = 0; j < 32; j++)
                ans += map[i][j];
        printf("There are %d black pixels.\n", ans);
    }
    return 0;
}

台長: Morris
人氣(1,917) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 413 - Up and Down Sequences
此分類上一篇:[UVA][迴文] 11309 - Counting Chaos

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文